LayoutTools2011 for Maya2011 (update)

By - - Maya
Duration
19 mins
Last modification: 16 Sep, 2017

This should be the final version (fingers crossed) of LayoutTools2011 for Maya2011 barring any unexpected bugs/issues. Thank you to those of you that provided feedback when I posted the beta over the summer. I was able to fix most of the bugs (e.g. the LT_form bug) that were reported and I even decided to add a couple of feature requests including a new feature for storing search paths and prefixes to a shelf (i.e. bookmarking).


Check out the following movie to see the most recent bug fixes as well as a couple of new additions.


This is a movie I recorded a couple of months ago that covers the more recent UI changes for the 2011 version.

And here is an older post that is more of overview of LayoutTools, including the new features from the 2010 version.

LayoutTools2010 Overview


 

LayoutTools2011 -> Install Package

LayoutTools2011 -> Installation Instructions


Note: After LayoutTools is installed and run for the first time, it can then be opened with the "l" hotkey.

  • "l" will toggle as a docked window.
  • "Shift + L" will toggle it as a floating window.
     

Also...  please post any idea for improvement or general feature requests in the comments section below.  I'm always looking for feedback. Thanks!

 

Posted By
Published In
Tags
  • Maya
  • Bonus Tools
  • Modeling
  • Tips and Tricks
  • Usefultools
26 Comments
To post a comment please login or register
| 8 years ago
LayoutTools 2012 beta is now available for download... https://area.autodesk.com/blogs/steven/layouttools
| 8 years ago
Thanks a lot Allya. Good catch! I have added that to the latest LT update which should be posted shortly.
| 8 years ago
Hello I've fixed a problem with the user selected path. It's just a lign to change in one file: file : LT_optionVars.mel lign 628 : [code]optionVar -sv LT_userImportPath ($path[0] + "/");[/code] change to => [code]optionVar -sv LT_userImportPath (fromNativePath ($path[0] + "/"));[/code] It's in " global proc LT_setUserImportPathName ()" function The problem is that the path given with the fileBrowserDialog is in the OS style, and not in maya style. For exemple, in windows the path is [code]D:\BrainCandy\Fray\Resources\Environment\Aros[/code] and in maya [code]D:/BrainCandy/Fray/Resources/Environment/Aros[/code] The " fromNativePath " function set the path in maya style. I hope this will be helpull.
| 8 years ago
rmulawa - for starters I only see the second part of your rant... where is the first? :) Otherwise I'm really sorry about the delay with LT. Typically I try to get LT out within a few weeks of the release if possible. However there has been a UI bug in the 2012 release of Maya that totally hosed the LT UI layout and it has been close to impossible for me to find the time to figure out a work around. I think I have found a solution but it's going to take me a fair amount of time to essentially convert the entire UI layout to a different format. Keep in mind that it's just me.. I created LT and I have to maintain it... and unfortunately I do it pretty much on my own time. As for having this functionality directly in Maya. I totally agree. It would be great if it were in Maya proper... I've pushed for it for years. But unfortunately it is not :( I'll keep pushing for it though! -sr
| 8 years ago
and I'd like to add one more thing to my rant! Why? Why? Why? Why the bloody hell is this not a standard past of maya? I can't tell you how much time I ahve wasted building the same god damn library of parts because maya has no preset library management system. I spend a hour looking for the bolt I know I have modeled 5000 times and can't find it then just end up modeling the same god damn part over again! What a bloody waste of time! Maya has been out for over ten years and they can't incorporate this as a standard feature into the application? FAIL FAIL FAIL! Every time I upgrade to a new version of maya I have to wait for LT to get ported to the new version and in the mean time my productivity drops exponentially because I have no visual preset library to search for and organize preset props!
| 8 years ago
Hi all First thanks to Steven for this wonderful tools. For those who have problem with running LTtools and having a error msg like this. LT_UI.mel" line 1055.51: Unterminated string. text -l " ? -al left -fn boldLabelFont; text -l " ? " -al left -fn boldLabelFont; you can just go to your "Region and Language" on your "control panel" under "Administrative tab Change system locale to English. Enjoy
| 8 years ago
Hi Steve, in 2012 Maya LayoutTools works but thumbnail generation or importing props does not. On my Windows 7 machine your script is not being able to read backslashes and failing to convert to forward slashes for Maya to be able to read. Where abouts could one fix this?
| 8 years ago
starc - sorry but LT wasn't designed to work with Z up. There are some notes/warnings in the doc about it. It was just too difficult to do.
| 8 years ago
starc, don't change the axis in Maya. It's not a good idea. Instead just rotate your model. A lot of things will break in Maya otherwise.
| 8 years ago
I have a quick question I`m using Maya in my work (architecture design) and I have to setup Z axis up as all models are coming from various softwares that have typically Z axis up. Is it possible to implement in Layout Tools option to switch from Y axis up to Z axis up (similarly to mr sun and sky)with all the tools working properly?
| 8 years ago
LT_UI.mel" line 1055.51: Unterminated string. text -l " ? -al left -fn boldLabelFont; text -l " ? " -al left -fn boldLabelFont;
| 8 years ago
please help me. // Error: "d:/Users/Administrator/Documents/maya/2011-x64/scripts/LT_UI.mel" line 1055.51: Unterminated string.
| 8 years ago
leebruce - what platform are you on? Do you get this error just by clicking the LT icon?
| 8 years ago
Hi please help me. I'm getting error // Error: Unterminated string. //
| 9 years ago
just downloaded LayoutTools. It is not seeing the FBX files in the library. Any tips?
| 9 years ago
Hi, I posted about Layout Tools 2011 for Maya 2011 update Issue. Layout Tools 2011 won't appear in my Maya 2011. Did it happen to you before ? I'm looking for solution to fix problem with this issues. Read my post at http://area.autodesk.com/forum/autodesk-maya/autodesk-maya-2011/layout-tools-2011-wont-appear-in-maya-2011/ I'm appreciated your time to read so hope anyone know how to fix it. I struggled and figured out how to fix it but I gave it up without anyone know advice about it.
| 9 years ago
Nevermind, I have got this to work now!
| 9 years ago
Hi Steve, I'm trying to add in V-Ray as my preferred renderer. I add these lines in, but no matter what LT will always use Maya Software renderer, how do I edit this properly? else if ($iconRenderer == "vray") { //or V-Ray renderer - but first setup some quick quality settings setCurrentRenderer vray; vrayCreateVRaySettingsNode;; setAttr "vraySettings.aspectLock" 0; vrayProgressBegin -preview $iconSize -y $iconSize -camera persp; print "Icon rendered with V-Ray renderer\n"; }
| 9 years ago
Hi please help me. I'm getting error // Error: text -l " ? -al left -fn boldLabelFont; // // Error: Unterminated string. //
| 9 years ago
Hi, Would you make some improvement tools I'd call it [ live-move-snap ] the matter is - too mach clicks you need to take to manipulate objects ... If you look at how this is done in sketchup you understand what I mean I guess it would be this way: when you take this new live-move tool, the coursore automatically trying to snap with nearest point, midpoint or face (there should be some options marked) on the object you want to manipulate with (maybe the pivot is automatically trying to snap to some points or midponts of the object where the cursor nearby) , so when you click - the cursor is sticked and you drag the object until you snap it to another object's pont or midpoint etc... or just type the distanse you want move it to the direction of the cursor move. Almost this way aoutocad work too Maybe some scripts already done ? Thank you Serge
Edited by NGGNXf6c 9 years ago
| 9 years ago
Hi, on some props I get this error message when using the import as reference option: "// Error: line 0: Flags must come before objects: -options" Maya 2011x64 Hotfix 3.
| 9 years ago
Hi Steven! Brief bug report: http://www.screencast.com/t/ZjhmNzQ1Y
| 9 years ago
I hope I am the only one but the video dies at about 1:20 just after you dock the pallet.
| 9 years ago
Thank You Sir! :) I've yet to use layout tools, but I can see it been very useful for an upcoming project. Just a few questions regarding Layout tools in general ( apologies for offtopic) - Does LT simply create a referenced object? - if so do I interact with the it like any other referenced objects? - Does it import the textures and shaders into the scene? - are there any speed improvements in the viewport by using LT? - Are there any rendering speed improvements using Mental Ray? - Is LT used mainly in game dev or do people use it for screen work as well? Thank you John
| 9 years ago
I don't quite get what you're saying?
| 9 years ago
best but my OS is x86 .could you make one .thanks
*Save $70 per month on Autodesk's Suggested Retail Price (SRP) when purchasing 1 year term 3ds Max or Maya subscription.